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Introduction 

Password Manager is a freeware solution to managing and using logins and passwords. It uses 

encryption built into Windows from XP (with SP3) and up. The best encryption it supports is AES 256 

with SHA-512 hashing. Password Manager can open URLs and auto-type your credentials. 

Your password is not stored anywhere. Your password is used to encrypt data (user names, 

passwords, etc.). When you set a password, your password encrypts a short phrase and when you 

log in, if your password decrypts this phrase, the decryption key will be able to decrypt the data 

stored. Again, your password is not stored in the program or the INI file, so if you forget it, it cannot be 

retrieved.  

You can export your password data to an Excel sheet. You can set a password for this Excel sheet, 

but do not consider it secure. Excel uses 40 bit encryption, which is easy to crack. I tested an online 

service and it only took the website 20 seconds to remove the password from a test document. An 

Excel backup is nice to have, but it would be wise to encrypt it with another application (there are lots 

of freeware out there, a good would be VeraCrypt).  
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Initial Setup 

When you run Password Manager for the first time, you will be prompted to create a password. A 

password is required, but there are no length or complexity requirements. When the password you 

enter and it's confirmation match, a message will let you know. If you are having trouble entering a 

password, you can click the button with an eye in it to reveal what you have typed. Clicking the button 

toggles between showing and hiding the password field. 

When you have set a password, it is time to set the encryption. You have several algorithms and 

hashes to choose from, but the best encryption available are the default values of AES 256 and SHA-

512. 

Save Settings and you will be taken to the main screen. 
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Using The Program 

Add An Entry 

The main window, shown below, starts as a blank slate. From here, you will need to add items. From 

there, you can use the program, edit items, delete items and re-arrange items in the list. 

To add an item, on the File menu, go to Add Item: 
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Now the following screen will appear: 

The required fields are Entry Name and Password, but if you do not enter any other information, you 

cannot open URLs or autofill. The user name and password fields are encrypted; others are not.  

Field explanations: 

 Entry: a simple title to display on the main list, such as Yahoo Mail, My Bank Account,

Facebook, etc.

 User Name: your user name (or email address, if the website uses email addresses instead of

user names).

 Password: your login password.

 URL: the web address to the login page.

 Double-Click Action: on the main screen this action is performed when you double-click an

item.

 Delay: After the URL is activated, wait this many seconds for the page to fully load before

typing the credentials.

 Number Of Tabs: Some websites do not default to placing the cursor on the user name field.

If this happens, count how many times you must press the Tab key to get to the user name

field. That is the number you should enter for this field.
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In the lower right corner, if you click the Advanced tab, it will expand to show more fields: 

None of these fields are required. They are just for your information. The previous password and 

secret answers are encrypted. The other fields are not. 

When you have filled out the entry, click Save And Close: 

Now you will see this entry on the main screen: 
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Right-Click Menu 

When you right-click an item in the menu, you have the following options: 

 Open URL & Autofill - This option reads your settings to execute the login URL, wait for the

amount of seconds you specified (delay), send the amount of tabs you specified (to get to the

user name field), and finally type the user name and password.

 Copy Username - simply copies the user name into the clipboard (in plain text - it cannot

remain encrypted in the clipboard).

 Copy Password - simply copies the password into the clipboard (in plain text - it cannot

remain encrypted in the clipboard).

 View/Edit Item - It brings up a similar window to the Add Item that allows you to see and edit

the data you previously saved, but with some extra buttons to quickly copy certain data to the

clipboard. Screenshot of this window below.

 Delete Item - Obvious, but it does ask if you are sure you want to delete the item, in case you

clicked this option by accident.

Edit/View Entry with Advanced tab showing
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Move Items In List 

If you choose to use the Sort: User Defined option in the File menu, you can move items up or down 

in the list by selecting the item and holding down the CTRL button and pressing the up arrow or the 

down arrow. This feature does not work when you choose Sort: A-Z instead of Sort: User Defined.  

When you add new items to the list, you can choose whether they are added to the top of the list or 

the bottom by going to the Settings page and clicking the option to add new items to the top or bottom 

of the list. 

<--Press CTRL + Up 
Arrow Multiple Times 

<-- The Item Is 
Moved Up In The 
List 
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Settings 

To Access Settings, use the menu to navigate to Edit > Settings. You will see this window: 

The options are: 

 Upon 3 failed password attempts, lock out user for __ minutes  - This is a security feature

that slows down someone trying to guess your password. On the 3rd failed attempt, they

cannot try again for the amount of time that you specify, which is between 1 minute and 60

minutes. The default is 5 minutes.

 Empty clipboard on program exit - This option clears the clipboard when you exit the

program so someone cannot come along and simply click paste to see what the last password

was put into memory. It does not clear memory when the program is simply minimized.

 Minimize program after double-clicking item - This option gets the program out of the way

when you have double-clicked and item.

 Minimize program after copying password - This option gets the program out of the way

when you have right-clicked an item and selected Copy Password.

 Prompt For Password When Restoring After __ Minutes - This is a security feature for

when you restore the program, you must enter your password to continue using it. By default, it

is not selected. Once enabled, if set to 0 minutes, it will prompt you for your password every

time you restore it from a minimized position. If set to 2, 5 or 10 minutes, it will not prompt you

for your password if restored before the amount of minutes; after the amount of minutes set, it

will prompt you for your password.

 Default double-click action - When you add a new item, this option sets the default drop-

down option for your double-click action.

 Add New Entries To The Top/Bottom Of The List – If your list is user sorted (not A-Z), it

adds new items to either the top or the bottom of the existing list.

If you click the X in the top right corner to close settings, your settings are not saved, it simply exits 

the window. If you want to save them, you must click the Save Settings button. 
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Change Password / Encryption 

On the Edit menu, you have the options to change your password or change the encryption used. 

When you choose to change password, you will get this screen: 

You are not required to log in the bring up this window because you do need to enter your password 

correctly in order to set a new one. This option isn't as fancy as the initial screen to set your password 

because you should know what you are doing at this point. 

When you choose to change encryption, you will be prompted to enter your password. Then you will 

get this screen: 

The window tells you what encryption you are currently using. You can choose a different encryption 

and/or hash algorithm. There is no need to change encryption unless you chose weak algorithms in 

the initial setup and decided to change to stronger options later. The default values are also the 

strongest encryption/hash algorithms: AES 256 and SHA 512. 
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Export Data To Excel 

To export your data to an Excel sheet, use the menu to navigate to Edit > Export Data To Excel. You 

will see this window: 

When you Export the data, a file called Password Manager - Exported Data.xlsx (or with the 

extension .xls, if you are using Excel before 2007). This data is protected by weak encryption that can 

easily be broken, so do not consider it safe.  

This is an example of an exported file: 
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Changelog 

2022-12-15 Verison 1.1 

Changelog 

 Due to screen resolution issues, the default font is now the system default instead of forcing it

to be Arial.

 Added Sort option to File menu

 Sort: User Defined - user determines order of list

 Sort: A-Z - list is always sorted A-Z

 Option Sort: A-Z does not allow user to move items up/down in list unlike the User

Defined option.

 In Add New Item section, added a password confirmation field and testing to make sure the

two passwords match.

 Previously, when saving an item's data, the sort order was set to 999 to put it at the bottom of

the list. Now, if the item already has a sort order (i.e. it already exists and is being simply being

updated), then the sort order is not modified. Therefore, if you edit an item, it will remain in the

user defined sort order it previously held.

 Added option in Settings when prompting for a password after 0, 2, 5, or 10 minutes. 0 minutes

option (default) will result in a password prompt every time you restore the program from

minimized position. Other times will give you that amount of time you do not need to re-enter

the password when restoring the GUI from a minimized position.

 Reduced the number of options on what double-clicking a item does. These actions now line

up exactly with the options available when right-clicking an item.

 Right-clicking an item shows a check mark beside it’s chosen double-click action.

 Added protection to prevent program starting off screen.

 Removed the “animation” of expanding and contracting the Add/Edit page. It either ran very

slow on slow computers or very fast on fast computer. Deemed unnecessary.
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2021-05-21: Verison 1.0 - Inital release 

Highlights: 

 Security as a priority.

 Password to open the program and access encrypted data is not stored anywhere.

 When you log in, it creates a unique encryption/decryption key that only works for the

current session. This key changed every time you are prompted to log in and is destroyed

when you exit the program.

 You have the options to minimize the program after certain actions and to be prompted to

log in again when it is restored.

 Uses a new coding technique (for me) to try and make it easier to make changes in the future.

I used Enum along with creating all GUI items in arrays. This allows me to add or subtract

items with code that is not as messy and automate some tasks such as hiding/showing

buttons, reading input fields and writing them to the INI file.

 Coded it so there are no dependent files needed. For encryption, it uses a DLL file included in 
Windows. The information icon used in a couple screens also are from Windows. Finally, the 
program logo in the About section and the eye icon (in the button to view or hide the password) 
are streamed into the script itself.

Ideas for future releases: 

When program is minimized, create an option to clear clipboard after a certain amount of time. 




